Til - Python Mirrors Strip Metadata

A very annoying discovery today. Some pypi mirrors strip out python_requires metadata. This means that you may install a version of a package that isn’t supported by your local version of python.

A fix is to edit the mirror in /etc/pip.conf but this admittedly very annoying.

Proud member of Hotline Webring